Installation

This section lists the dependencies of GopPy and provides installation instructions. The installation is quite easy as GopPy is a pure Python package.

Requirements

GopPy supports Python 2.6, 2.7, 3.3, 3.4, and 3.5. Later versions will be likely to work, too. In addition, the following package will be needed:

If you want to run the unit tests, you will additionally need:

If you want to build the documentation, you will need:

Install with pip

You can install GopPy easily with pip:

pip install goppy

Install from Source

It is also possible to download the latest source distribution from PyPI, extract it and run:

python setup.py install